Topic: Wells Fargo

I got an invalid response code 500, which stands for Invalid response code from OFX server: Internal Server Error....

Is there anyone else got the same error with connecting to Wells Fargo, please?


Re: Wells Fargo

I am getting same error, did you get around this somehow?

Re: Wells Fargo

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Re: Wells Fargo

For anyone else trying to get PocketSense scripts to work, here is a thread from the PocketSense blog that may be helpful. I had to add the AppVer and AppID fields to my setup in July 2013....

humblepieJuly 22, 2013 at 7:33 PM

Am using PocketSense scripts with MS-Money sunset edition. All has been well for a couple of years until recently. I've been struggling of late to make a successful connection to Wells Fargo. I received a message indicating "software version is not supported." It may not be obvious to everyone, but download support for Quicken versions are phased out after 2 years. Therefore, it would seem we have to keep updating the APPVER field about once every 2 years, since we are "tricking" Wells Fargo into thinking we are downloading data for Quicken. As of tonight, I guessed at the following settings in sites.dat and now I am able to connect/download my accounts. (Next year or the year after I will change 2200 to something like 2400.)
appid : QWIN
appver : 2200

I'm not certain whether it is necessary or not, but I went ahead and ran through the PocketSense script and re-entered each account at Wells Fargo before testing. Hope this helps anyone else out there with similar troubles. BUT, Robert, does this make sense? It's hard to argue with success, but I can't help but think I've got something wrong. (Thanks so much for all the hard work!)

    RobertJuly 23, 2013 at 4:59 AM

    Thanks for posting. Yes, the version update makes sense, but most providers don't cutoff support that quickly. That said, you do *not* need to re-enter your account data. Just change the appVer field in sites.dat for the site. I'll update the default value in the next release to a more modern version (2100 or 2200). It's currently at 1900.

Re: Wells Fargo

Humble Pie,  Thanks for the helpful post.  Could you post fiorg, fid, url and bankid for Wells Fargo Bank (checking, etc) and Wells Fargo Advisors (investments)?  I have good success with Vanguard, AMEX, etc, but can't seem to get Wells Fargo ofx to Money Sunset.  I must be close, cause I got an autoresponse email saying "thanks for signing up" from WellsFargo.

Re: Wells Fargo

Glad to help.  Here's exactly what is in PocketSense sites.dat file.  Note though that I live in Georgia and the Routing number is for Georgia. For completeness I've included Wells Fargo Advisors too.  Good luck!
PS - This blog site won't allow me to paste more than one url in this post. You'll see in Wells Fargo Advisors where I indicate to copy the url from the first site's entry. (and you'll need to remove the and tags too)

    SiteName   : Wells Fargo Bank 061000227
    AcctType   : BASTMT
    fiorg      : WF
    fid        : 3000
    url        :
    bankid     : 061000227
    brokerid   :
    appid      : QWIN
    appver     : 2200
    timeOffset :

    SiteName   : Wells Fargo Advisors
    AcctType   : INVSTMT
    fiorg      : WF
    fid        : 12748
    url        : *** same as the link above!!!!!!  ***
    bankid     :
    brokerid   : Wells Fargo Advisors
    appid      : QWIN
    appver     : 2200
    timeOffset :

Re: Wells Fargo

Thank you, humblepie.  I didn't realize the bankid was the routing number; and in some cases Wells Fargo checking may be in Wells Fargo Advisors accounts where, I assume a BASTMT might apply to a Wells Fargo Advisors site.  But, with your good work I should be able to work thru the permutations.

Re: Wells Fargo

You're welcome. Um, embarrassingly I said:   (and you'll need to remove the and tags too)
That referred to the start url and end url tags. But of course, they don't appear in the post anyway!  So not to worry.  Hope all works well for you.

Re: Wells Fargo

On June 17, 2016, I started receiving this error on all my client's accounts:

<MESSAGE>The financial management software you are using is no longer supported. Please upgrade your software or contact us at 1-800-956-4442 for assistance. (2000:9)

I've called the suggested phone number, and after elevating to a "Supervisor" I still received no useful information.

I'm using:
Bank ID:102000076
Org: WF

With "OFXHEADER=100", I've tried both "VERSION=100" and "VERSION=103".  The latter with a Client ID included in the request.

Re: Wells Fargo

Yeah, I started getting that a couple of days ago myself.  As you saw I had AppVer:  2200  so I increased it to AppVer: 2400 which buys me 2 more years.  Why not set it to 3000 you may ask?  I don't know...but have figured I might as well stay in line with what Quicken uses.  Plus, by going through this silly exercise every couple of years I won't forget the lesson!

In your settings you didn't mention appid nor appver.  I believe you'll need them both.  appid: QWIN  appver: 2400

Give it a try and run again one time, then run and you should be good to go.

Re: Wells Fargo

AppVer=2400 fixed it for me.  Thanks!

Re: Wells Fargo

I started having problems with Wells Fargo starting in June 2017.  I am using GnuCash v2.6.14 on Mac (Intel).  I was getting Generic Error 2000 no matter what settings I used in aqbanking setup.  I tried deleting and recreating the account but that also failed.

I called Wells Fargo and they said Quicken 2014 is no longer supported and it was officially tuned off in June.  You have to use Quicken 2015, 2016, or 2017.

So, The OnLine Banking Settings for GnuCash for Wells Fargo have changed as follows:

User Settings tab - you must have a Client UID so if this field was blank before you now need a value

Bank Settings tab - no changes required
Bank Name=Wells Fargo Bank
Broker Id=<leave it blank>
Server URL=

User Settings tab - must change Application Version and Header version
Application Id=QWIN
Application Version=2600 (Represents Quicken 2017)  (previous setting was 2300 which Represents Quicken 2014)
Header Version=103 (previous settings was 102)
Special Settings are all blank (or not changed from default)

Re: Wells Fargo

This URL no longer works:

Re: Wells Fargo

I tried with the new URL but I am still getting response code : 500. I am using :

Can anyone suggest something?

Re: Wells Fargo

We had to switch over to use BAI in order to get our transactions.