Topic: Charles Schwab Bank, N.A.

This institition has a crazy login system for OFX...
Username is web login username
Password is web login password trimmed to 8 characters
BANKID is the routing number, 121202211
account number must be normalized, so if yours is 4400-12345678, it must be passed as 00000440012345678

Re: Charles Schwab Bank, N.A.

In my experience, all requests with start dates before 90 days prior to the current day will fail silently.  It seems to be a timeout on the connection.  The OFX response will show success, but no transactions will be shown.

3 (edited by benderguy 2011-02-07 07:07:25)

Re: Charles Schwab Bank, N.A.

setting up my checking account with PocketSense, I needed to use the following:

    SiteName   : Schwab Bank Checking (can be anything here)
    AcctType   : BASTMT
    fiorg      : ISC
    fid        : 101
    url        :
    bankid     : 121202211
    brokerid   : SCHWAB.COM
    appid      :
    appver     :

account number: 000004400-12345678 (assuming my account number looked like 4400-12345678 as seen when logging into website - add 5 leading zeroes)
my username and pwd were the same as when logging into the account website.

Re: Charles Schwab Bank, N.A.

Passwords apparently no longer need to be truncated to 8 characters, but there are restrictions on special characters for the OFX server that aren't in place for the Schwab web site. If you get the error, "Account information may contain bad or invalid characters such as spaces." you might need to change the password to include only numbers and letters.

Re: Charles Schwab Bank, N.A.

Recently downloading with curl stopped working, which I'd been using for years. I found out that the header "User-Agent: curl/7.47.0" was making the download hang. Removing the User-Agent header entirely fixed it.

Re: Charles Schwab Bank, N.A.

You are a lifesaver Peter, thanks!


Re: Charles Schwab Bank, N.A.

Has anyone verified whether the proscribed OFX settings still work? I am currently unable to retrieve balances or transactions. The last time I tried this was late February, 2020, and it worked then. Here is my GnuCash log:

AqBanking v6.2.2.0stable
Sending jobs to the bank(s)
Sorting commands by account
Sorting commands by account
Sorting commands by provider
Send commands to providers
Send commands to provider "aqofxconnect"
Locking customer "1"
Sending request...
Connecting to server...
Resolving hostname "" ...
IP address is "XXX.XXX.XXX.XXX"
Connecting to ""
Connected to ""
Using GnuTLS default ciphers.
TLS: SSL-Ciphers negotiated: TLS1.3:ECDHE-RSA-AES-256-GCM:AEAD
Sending message...
Message sent.
Waiting for response...
Receiving response...
HTTP-Status: 403 (Forbidden)
Unlocking customer "1"

I removed all of my Schwab-related users and accounts and recreated them per these instructions (Charles Schwab Bank, N.A., is the second set under that heading). Still nada (with or without brokerId="SCHWAB.COM").

Any advice? Any additional diagnostics I can conduct?