Topic: JPM Chase Error beginning on 2/1/2014

On Feb. 1, I started getting this error for all my client's accounts at Chase:
  "The underlying connection was closed: An unexpected error occurred on a receive."

These are a mix of bank and credit accounts, and I had been using:
  Org = "B1"
  FId = "10898".

These settings have been working for months.  I haven't tried the Oasis URL.

Anyone else have problems or know of any change that took effect on Feb. 1?

2 (edited by wayubi 2014-02-05 23:08:19)

Re: JPM Chase Error beginning on 2/1/2014

Hi gStorm,

I have had the same issue over the last few days and have been diligently debugging it.  It turns out that the User-Agent MUST be set.

CURLOPT_USERAGENT => 'asdf' will work fine.

CURLOPT_USERAGENT => true will also work fine.

CURLOPT_USERAGENT => '' will not.

Re: JPM Chase Error beginning on 2/1/2014

Awsome find, wayubi!  I was having trouble debugging, and not even looking at the header.  The user-agent solved my problem.  Thanks!