Topic: Direct connect accounts edited or created with aqbanking don't work


I thought this was specific to my capitalone account, but I see it's not.

Despite just upgrading to F21, I have the same problem, even after uninstalling/installing gnucash and aqbanking, and removing the config files for both.

1. I previously had an account working PERFECTLY with direct connect/aqbanking.  However, as I was trying to fix another account, when I edited it and saved it, it blanked the "bank code" and sets it to 00000000000.  It also doesn't save which emulated application is chosen, always showing "Select" after you reopen it after saving it.  Now I continue to get invalid user/pass with this account, no matter what.  I had it working fine yesterday.

2. Despite going into .aqbanking and editing the user directly and readding the bank code manually, I still get the same error when trying to fetch transactions(invalid user/pass).

The bottom line is, it seems any user I add/edit with aqbanking now no longer works, and the bank code resets to 0000000000000, and whatever emulation is chosen doesn't save.